One-Click Root for Stock Gingerbread (Droid X, Droid 3, Droid X2, Cliq and Cliq 2) [From the Forums]

Earlier today we reported XDA forum member dirbliss had successfully rooted the Motorola DROID 3. Now, thanks to Framework43, krazykrivda, and psouza4 over at rootzwiki, we have an uber simple one-click root method for stock Gingerbread. I have tested this out on my Droid X running 4.5.602 and everything went flawlessly. As per P3Droid, this method should work on the Droid 3, Droid X, Droid X2, Cliq and Cliq 2. Here’s how it goes down, but proceed at your own risk:

  • Motorola drivers need to be installed – 32bit here and 64bit here
  • Download and unzip ‘Droid 3 easy root script v7′ to your PC  from here
  • Turn on USB debugging on your phone by going to Settings > Applications > Development > USB debugging(check box)
  • Plug phone into your computer and select “Charge Only” mode from your phone’s notification drop down (pull down your notification bar and tap USB connection to change).
  • Navigate to ‘Droid 3 easy root’ folder you unzipped to your PC and run ‘Click to root your Droid 3.bat’
  • Now just follow the instructions in the command window and unlock the phone after each reboot

No more SBFing back to Froyo on the Droid X! Thanks to everyone that set this up. Make sure to check the source link below for any updates.

WARNING for Droid X: Previously rooted DX owners who took an OTA update and then lost root should proceed with caution. This seems to only work flawlessly on SBF’d DX’s or fully factory stock ones(read: never been rooted). The problem is with getting Superuser installed because it is already on your phone from when you were rooted previously.

[via rw]

» See more articles by Harold Williams


Google+0Facebook0Twitter43
  • http://talkandroid.com BKyle

    This is exactly what I’ve been looking for, so thanks for the info. Just one question. How do you navigate to the folder, from the PC I presume, if it’s in Charge Only mode? I couldn’t open or access any files on the phone while in this mode. Please forgive me if this is a dumb question.

  • Ashton

    Do we download the drivers and droid 3 easy root script v7 to the computer or the phone? Sorry I prefer exact steps for minimal mistake

  • Jim

    I’ve tried several times with the instructions above and cannot get it to root. DroidX with 602 OTA installed. It was previously rooted in Froyo with Z4. Used Wireless Tether to test root. Would love more info as to why it isn’t working. Thanks, Jim.

  • http://www.talkandroid.com Harold Williams

    @BKyle – Yes, the ‘Droid 3 easy root script v7′ needs to be downloaded and unzipped on y our PC.

    @Ashton – Computer. I’ve updated the instructions.

    @Jim – What state was your Droid X in before you started? Stock GB .602?

  • Jim

    Yes, stock GB 602. Had tried several options already, GingerBreak 1.2, etc., and Superuser was already installed from Froyo root, if that matters. Thanks, Jim.

  • Ashton

    Thank you harold

  • http://www.talkandroid.com Harold Williams

    @Jim – You should get yourself to absolutely stock Gingerbread OTA. If you have the setup to flash back to Froyo do that, but leave it stock and grab the OTA to Gingerbread .602. There is a Gingerbread OTA floating around as well so you don’t have to flash back to Froyo. Let me know if you can’t find it and I’ll hit you up with a link.

    @Ashton – Welcome.

  • Jerry (Lughead)

    Please get me the link for the gingerbread OTA

  • Jim

    Harold, a link would be great. Are you saying that the Verizon GB update is not stock, because the Froyo was rooted previously? I may be getting confused. I had Z4 rooted Froyo, no additional mods, then on Monday I did the Verizon update to GB .602. I lost root at that point. I have tried the GingerBreak yesterday but it just hung every time. I have tried the one click method several times on a Win7 64-bit and 32-bit machine. Every time the message says it worked, but the phone is never rooted. I make sure of Charge Only and USB Debugging every time, and unlock the phone after each reboot. Any thoughts? Current System Version is 4.5.602.MB810.Verizon.en.US; 2.3.3; Baseband BP_C_01.09.13P; Build 4.5.1_57_DZ5-32. Thanks again for your help. Jim.

    • http://www.talkandroid.com Harold Williams

      @Jim – I think the problem you are having is that you took the .602 OTA from Froyo that was already rooted. That may cause problems trying to install Superuser.

      If I were you I would do this since I haven’t tried the GB SBF yet myself (assuming you know how to flash an SBF file). Grab the Froyo SBF here and flash it with RSD light. When it’s complete and your phone restarts, pull the battery, boot up into stock recovery by powering on the phone and holding the HOME key, and select factory wipe like 3 times (just to make sure everything is wiped clean) and wipe the cache.

      At this point you’ll be at stock Froyo. Update your phone with the OTA to GB .602. Once this update is done you should be at a COMPLETLY stock GB .602 and you can give the root method in this post another shot. If you want to try to SBF right to GB .596 (which will need to be updated to .602 with OTA) you can grab that here. Again, I like to so a few factory resets after SBFing just to make sure everything is nice and clean. I hope this helps.

      Are you looking to try out some ROMs on the Droid X? If you are I’d also suggest once you get clockwork recovery installed you make a backup right away.

  • Nick

    I have the same problem as Jim. I had froyo stock when I got the phone and used Z4 root to root my droid X. When the new gingerbread update came I updated with the OTA version. I lost my root access to my phone and have been researching to get it back. I used the one click root, it said rooted but using root checker from the app market it said I did not have root access. If you can give me any assistance it would be greatly appreciated. Thanks.

  • Jim

    Harold, FYI, user KevlarGibs on the Rootzwiki forum posted this solution to the previously rooted DroidX.

    In adb shell type:
    mount -oremount,rw /dev/block/system /system
    rm /system/bin/su
    rm /system/xbin/su

    Then re-run oneclick. Worked for me. Don’t understand the process, but thought I’d pass it along. Thanks again, Jim.

  • http://www.talkandroid.com Harold Williams

    @Nick – Looks like your in the same situation. What I just posted should help.

    • http://www.talkandroid.com Harold Williams

      You can try this other method here. There are instructions to use RSD light if you need them.

  • Rob

    Define “unlock phone at each reboot” pls.

  • http://www.talkandroid.com Harold Williams

    @Rob – When the one-click root method is running your X will restart a few times. Upon restart, the screen will be locked and you can unlock the screen with the sliders. I didn’t do this though and the process went fine for me.

  • Rob

    Thanx. Kinda what I figured. Trying on X2 and hasn’t been successful yet. Not sure if it’s me or that I’m using the wrong incantation :-) when I do it.

  • http://www.talkandroid.com Harold Williams

    Just a note on the SBF files I posted above. Those are for Droid X.

  • chris

    does this work on x2′s as well?

  • Nick

    Thank you for the assistance. I have hopefully one more question though. I did a system wipe as instructed above on the Gingerbread figuring that may get rid of the superuser icon. I think the device is recognizing it is rooted still because i never technically unrooted it i just updated to the OTA gingerbread software. DO you think sbfing back to the froyo 2.2 would allow me to get rid of the icon or do i have to us Z4 root with the 2.2 update to unroot then OTA update to Gingerbread.

  • http://www.talkandroid.com Harold Williams

    @Chris – The method is the post shoudl work on your X2 if you are 100% stock GB.

    @Nick – Are you in the same situation that you had previously been rooted and then took the .602 OTA? In that case I would SBF. If you follow what I said in the above comment it will get you back to 100% stock. Let me know if that doesn’t really answer your question. Once you SBF there is no need to use z4root anymore if your going to use the one-click method. Hope that helps.

  • http://talkandroid.com BKyle

    Thanks for your quick response. So I saved it and extracted files on my PC but how exactly do I run the program? Via Phone or PC? And with what method? DX2

  • http://www.talkandroid.com Harold Williams

    @BKyle – You have the phone plugged in via USB with debugging mode on and the USB connection set to “charge only” on your phone? If you did all the steps listed in the post there is a .bat file in the folder you unzipped on your computer called “Click to root your Droid 3.bat”. Run that and it will do the rest for you.

  • http://www.talkandroid.com Harold Williams

    If you guys are really having trouble I can post a video of how this all goes down, but it should be simple and quick as long as your totally stock. Remember, if your looking to try out CM7 for the Droid X you’ll have to use a different method.

  • http://talkandroid.com BKyle

    Thanks. I followed all of the steps that you mentioned and received the following error message, just after pressing Run: “The application failed to initialize properly (0xc0000142). Click ok to terminate the application.” Any advise?

  • http://www.talkandroid.com Harold Williams

    @BKyle – I would hit up the source thread. There seems to be some updates and fixes for people having issues.

  • Robert

    Now that I’m rooted what can I do with it? I cant find anything for rooted 602!

    • http://www.talkandroid.com Harold Williams

      @Robert – What I did, awaiting ROMS to be ready for .602, is make a back up of it. This way as I play around with CM7 and various others, I can quickly just reload the rooted .602 backup from clockwork and rock on from there.

  • Kevin

    tryed this 5 times, and it has yet to work followed everything to the T.
    all it does is
    ‘adb is not recognized as an internal or external command,

  • http://www.talkandroid.com Harold Williams

    @Kevin – What phone do you have and what state was it in before you started?

  • Robert

    @Kevin – That was happening to me; I right clicked “Click to root…” open; Extract all, Extract then “click to root…” then “run”…

  • http://talkandroid.com BKyle

    Now I’m at the same point as Kevin. Getting this “adb is not recognized as an internal or external command” and pretty sure I followed all of the instructions in your last response to Kevin. Thanks for all the help and I feel like I’m so close. Do I need to Run from a particular location on my PC?

    • http://www.talkandroid.com Harold Williams

      For you guys having a lot of problems and don’t mind SBFing, try the other method I posted here. It might save you some headaches.

  • http://talkandroid.com BKyle

    Nevermind. I moved the file around, unplugged and reconnected phone, and tried it again… I’m rooted. Thanks for your patience.

  • http://www.talkandroid.com Harold Williams

    @BKyle – Cool, glad you got it figured out.

  • SamC

    This looks exactly like the perfect method I wanted, but I’m having trouble.
    DroidX original, never rooted, upgraded to stock 4.5.602, downloaded and installed drivers for 32bit, , phone on charging and plugged in USB w/ debugging and ran the batch file on PC. Problem is that my phone goes into the black loading screen, and it never finishes rebooting, even after 20 min or so.

    Am I doing something wrong here? Really would appreciate any help b/c I really wanted to root without having to bother with sbfing.

  • Amy

    I want to know how many takes time is this…?
    Now It has been processing..DDDDDD^^

  • Charles

    I was in the same boat as these other fellows. Prior to the 2.3.3 upgrade, I had rooted. At this point, I was at the 602 version. Even though I no longer had root, the superuser icon continued to show up in the app listing. After installing SDK with this very good explanation
    http://www.addictivetips.com/mobile/what-is-adb-and-how-to-install-it-android/
    I then used a variation of Jim’s suggestion to remove the two su files as soon as I realized this was a flavor of unix. Within ADB, I started the sheel, then changed to su, then changed directory to each of the two directories Jim named, and removed each of the two su files. Then I powered off the phone, powered on. At this point the superuser icon no longer appeared, and the one-step process in this thread worked successfully! Thanks to all!

  • Rob

    First off… You’re all incredible and I enjoy watching, reading, learning and trying. Second, I acheived success on my DX2 by going back to 2.2, then doing a clean OTA update, then running the one-click miracle. I am resetting up house-keeping as we speak. Thanks again to you all for your wisdom and patience.

  • Kevin

    Hay Harold, I have a stock droid X. i downloaded Z4 and did a temp root a few days ago and thought this is cool but had faults with gingerbread so reset everything to factory. updated everything and sence the new interface (dx2? ) it changed the look and some buttons, nothing works. tryed to use z4 and no go. this … nope.

  • ptvolkmar

    Awesome work

  • http://www.talkandroid.com Harold Williams

    @Kevin – You can’t currently use Z4 on Gingerbread for the X. If you want to do it that way you have to SBF back to Froyo, root, and then flash a few files to get to rooted GB (which is in my previous post you’ll find above in the comments). If you tried to use Z4 on stock, that might put it into a state that the one-click won’t work. Id SBF and start over fresh.

  • JoeDroid

    If I need to unroot, what is the process?

  • http://www.talkandroid.com Harold Williams

    @JoeDroid – you’ll have to SBF to stock Froyo or previous build of GB

  • JEREMY

    How long should this take to complete?

  • http://www.talkandroid.com Harold Williams

    @Jeremy – 30 seconds maybe?

  • JEREMY

    I have a fresh phone from verizon and when I start the process it recognizes the phone then says rebooting phone and it goes into bootloader mode and thats it any help woould be great.

  • Reno

    Just wanted to say thank you. This was so f’ing easy and I’m glad I finally f’ing made the decision to be rooted. I’m dumb for waiting so long.

  • Fabian

    I have wiped all data on my phone [gingerbread stock]
    and i am on prosedure 1 of 3 and its stuck saying rebooting phone……please wait.
    ive been waiting for a good 15 min.
    nothing has happend my phone is on bootloader screen please help.
    Fabian.

  • mac

    Awesome, just download the 32bit or 64bit and then install, then sowload the script unzip it follow the directions andwham ur phone is rooted. One note: when phone reboots just might have to pull the USB cable and plug back in for each stage of the root process. Thank you guys

  • Nick

    WOW that was easy… i have been looking for this for awhile thank you

  • JEREMY

    To anybody whose phone is going into bootloader and stopping try this unzip file to desktop and reboot PC then follow root steps. I’m not a tech guy but I had this problem and thats all I changed and my phone rooted in seconds.

  • vas

    Thanks so much. Worked like a charm on Droid X

  • Andrew

    I ran the software and the phone rebooted twice (as mentioned). The software window said everything completed successfully, but when trying to run root-only programs it says my DX isn’t rooted. Any suggestions?

  • Fabian

    @JEREMY Thank you so much man ha it worked!!

  • Warren

    Genius! It worked! I knew if I just sat back and be patient that someone would figure it out! (I didn’t want to SBF either! LOL)
    For those of you getting the Bootloader screen when the phone first reboots… Unplug the USB cord, push the power button to turn off the screen, press and hold like normal to reboot phone. When the “M” logo pops up, plug the cord back in. The phone will reboot, DO NOTHING! After the phone reboots and the connection is detected between your phone and computer, step two will start and the phone will reboot into the bootloader screen again. Do the same thing each time, it will work.

  • Fabian

    okay i kinda take that back, it said it rooted but wireless tether is not working on my DX i even downloaded root check and it said im not rooted.

  • Zack

    When the phone reboots to bootloader, just unplug the phone from USB, manually start to reboot it, then plug it back in when it’s rebooting. The script will continue from where it left off.

    The one click worked perfectly for me on DroidX! Root check confirms I’m rooted.

  • loki

    Just also want to leave a message for those who were at my skill level (knows nothing) coming from a pre-rooted phone and now stuck:
    1. Had stock froyo rooted with Z4
    2. Had the official pre-rooted gingerbread back in May.
    3. Accidental OTA upgrade to 4.5.602 gingerbread, half-lost root, no actual root function but still had an non-functioning Super User on it. Tried factory reset, but still had the Super User.
    4. Tried this one-click root and it didn’t work.
    5. Used Jim’s reposted method using ADB (see above), but I didn’t know how to use ADB (Android Debug Bridge) or heard of it before now.
    6. Downloaded ADB, installed it. Launched windows command prompt and went to the “platform-tools” sub directory of where ADB was installed (e.g. c:\programs files\android… etc.)
    7. typed adb shell to start the shell.
    8. Type each line in one at a time. It will not give any confirmation.
    9. Closed it and re-ran one-click, now rooted.
    10. I apologize if this is an inappropriate comment, but it took me a lot of reading to make sure I was doing it right, but no one actually gave a dummies step by step guide for it.
    11. Thank you Jim for your comment/repost.

  • Antelope

    Ran the above on stock GB after having z4 on froyo. Had to do the unplug USB cable thing, now I’m back to root and loving it. Thanks for everyone’s input.

  • DaveG

    loki’s procedure just worked for me as well — at least, root is reflected in a couple of programs that look for it. The directions on how to use ADB did the trick — I also restarted the phone after the ADB actions and before running one-click, per an earlier message here. Don’t know if it made a difference.

    Thanks to all who discovered the magic and all who told the less technically adept how to make it work.

  • Mac

    Worked like a charm first time out with GB4.5.602 that was previously rooted under Froyo with Z4root. But how to unroot when the time comes?

  • JimD

    Jim/loki,
    That adb fix worked like a charm on my DroidX, have a rooted GB 4.5.602 and what a relief!
    I did the accidental upgrade too so I was relieved when I saw the fix.
    Thanks again!!

  • timrog

    i tried a few time and it wouldnt root. now i want to sbf back to froyo. could someone please send me a link and instuctions to the most safest way to sbf. im running win 7 64 bit. timrogers1956@yahoo.com

  • buddha

    did this on my droid x and worked perfectly. i am now wondering what i need to do to get bootstrap recovery or some type of recovery so i can backup my rom before installing a custom. thanks!!

  • barkerman

    Thanks to everyone who put this together, and commented. This worked like a champ for me, on my Droid X.

    Many thanks.

  • Mike

    This works like a charm. Super fast and easy

  • Caitto

    I am very confused. I followed the steps. I was one froyo Z4 but i hard reset the phone to gb .602, when i run the Droid 3 Easy Root Script v7 the phone restarts a number of times then says everything was a success. On the phone the super user is installed but the phone is not rooted.

    • http://www.talkandroid.com Harold Williams

      @Caitto – it’s because you were already rooted in Froyo. Take a look through the comments to reset yourself.

  • Dani

    Finally, I’ve been waiting for this since OTA. Great job, it worked perfectly on the first try.

  • McGregor

    So i tried this and after the first reboot I got a little droid logo with a caution sign above him. What went wrong?

  • Caitto

    Sbf back to froyo and updated everything is great, mcgreg pull the battery and restart

  • Dr. Piranha

    Hey, thanks for the guide on how to root GB .602 stock! I was hoping on using a method where I could just download an app, and click “root”, because I don’t really have any expertise like you guys/gals, at hacking phones, but I’m willing to try this method, but had a couple of questions first.

    - When people say “do a clean wipe” or stuff like format the sd card, what exactly does that entail? Does that mean use a separate SD card that has no data on it? Or do I need to reformat my current SD card, or whatever card I choose? I assume I can back up everything on the card that I would need to go back to unrooted, if I didn’t like it?

    - Also, I saw someone say you can’t use CM7 with this root method? I thought once you were rooted, you could install any custom ROM’s you wanted to? Is this a limited kind of rooting method that won’t be compatible with all the cool things that rooting has to offer? That would be a bummer, if I’m going to root, I sure don’t want to do it half-assed, and not get to enjoy all the things like wifi-tethering to my Galaxy Tab 10.1, and all the other benefits I’ve been reading about.

    - I assume that all the things you’re supposed to download “the driver” ect, are downloaded to your computer? And regarding that, does it need to be a Windows based computer? I would prefer to do this with my iMac, but I also own a Windows 7 laptop.

    So any help would be much appreciated, I’m really looking forward to gaining root access, as it seems to have a lot of benefits, and only minor disadvantages, and of course I just wanted everything clarified, seeing as I can’t currently afford to “brick” my phone. So I guess it is probably wise to do all of this on a new SD card, so I can go back and install my current SD that has all of my stock .602 on my Droid X? Thanks again to whomever can provide some assistance, and remember, I don’t have any former knowledge of rooting smart phones. I am computer savvy, but just not pertaining to this. Thanks :P!

  • Dr. Piranha

    p.s. Sorry I forgot to mention I’m currently on a stock Droid X running Gingerbread .602. I’ve also never rooted before.

  • http://www.talkandroid.com Harold Williams

    @Dr. Piranha Ill try to hit all your questions here:

    -When you see “clean wipe” that means re-flashing the OS on the device putting it back to “stock” as it was out of the box. You should see some instructions above to do this.

    -If you want CM7 currently, youll have to flash back to Froyo as it run off of the Froyo kernel. Using .602 that your currently on you can run ROMs like APEX. To get you started, I would research how to properly flash your phone with an SBF BEFORE you start rooting as this is the only thing that will save you if you screw up.

    -I BELIEVE you can use this method on the back but I would refer to the original source link to check.

    If you’re not even sure why you want to root, I would stop at this point and so some research. You’ll need to be able to find the SBFs you’ll need, know how to flash them with RSD light, know how to flash a ROM once your rooted. If you are OK leaving your e-mail here I’ll help you the best I can. Comments might not be the best way to get you started.

  • McGregor

    After rooting all my apps are missing from app drawer. How do I get them to reappear?

  • LaRoyDen

    First of all thank you for all this information. Awesome!
    Secondly, after this GB one click root works, can you recommend a sure way for wifi tethering? I have found a lot of mixed thoughts/reviews on working apps. Any help would be great.

    • http://www.talkandroid.com Harold Williams

      @LaRoyDen – I personally got sick of fiddling with that stuff and pay the 20 bucks a month for it from Verizon.

  • LaRoyDen

    Well that is to bad. I use tethrering exclusively for my internet. I guess until a reliable option is available, froyo it is..sucks! If anybody knows an option let me know! Thank you

    • http://www.talkandroid.com Harold Williams

      An option is to pay for it…it works great I use it every day =)

  • LaRoyDen

    Haha not going to happen! Thanks for the help though:)

    • http://www.talkandroid.com Harold Williams

      I played with Barnacle from the market a bit. Check that one out.

  • LaRoyDen

    Thanks a lot for your time. Its really nice to have cool people with knowledge share their skills.

    • http://www.talkandroid.com Harold Williams

      Glad to have readers checking out and interacting with our posts. Anytime.

  • Steven

    Did the whole process. It rebooted twice. but still no root. I was on stock gingerbread.

  • Steven

    It says running exploit part 1 of 3. server not running.

  • Shiznitz

    I was on a rooted Froyo, tried this and it didn’t work. It seems that I cannot run the steps outlined either, since the adb shell won’t allow me to run “su” (permission denied). I can’t even do the mounting command.

    Any ideas?

  • Joe M

    One-Click Root for Stock Gingerbread , does it work on AT&T Motorola Atrix?

  • Brian

    Maybe I am being impatient but I have done the steps and am still waiting at time of this post for over 12 minutes…Seems to be stuck. I dont want to unplug and brick my phone. Any advice?

    • http://www.talkandroid.com Harold Williams

      What state was your phone in before you started. Were you rooted before.

  • Cameron

    @Shiznitz – I am in the same boat as you. Started on Froyo and ran z4root (months ago). Then OTA update happened and I’m now on 2.3.3 (4.5.602) but no root. When I run [adb shell] and su I receive permission denied…

  • Chuck Jones

    @Cameron and @Shiznitz. I’m in the same boat. Rooted Froyo a while back, OTA upgraded to 602, SuperUser still displays, ADB commands yield permission denied, just flat stuck. Any way to delete those two files via a mechanism other than an ADB shell?

    • http://www.talkandroid.com Harold Williams

      If you were rooted before you need to sfb

  • Tom Jerry

    Hi, i tried this method and im still not getting rooted. Im on OTA gingerbread 2.3.3 and didnt do the rooted for froyo, and i have no idea what the 602 build means.i tried using the SD(adb shell) but that didnt go so well since i couldnt get it to work. any help would be nice thanks!

  • Droid 2 User

    Flawless! Super Easy! Thanks!

  • Fabian

    @Harold Williams
    how do i get my droid x to stock gingerbread cause im on ginger bread now but idk how to put it to stock.

  • http://www.talkandroid.com Harold Williams

    @Fabian – have you ever rooted your phone before? If you haven’t then you are “stock”

  • Fabian

    @Harold Williams
    Yeah when I was on froyo.

  • http://www.talkandroid.com Harold Williams

    @Fabian – Youll have to SBF. SHuld be instruction in the comments here. Search the posts for the most recent .602 SBF file

  • TonyC

    I’m having similar problem as SamC:

    DroidX2 original, never rooted, upgraded Gingerbread, downloaded and installed drivers for 64bit , phone on charging and plugged in USB w/ debugging and ran the batch file on PC. Phone rebooted twice but never came bak from the 2nd reboot. It’s stuck black loading screen. I waited a good 1/2 hour, but now can’t even get it to power on. Tried removing battery/sdcard, tried power-vol down, power-home key, nothing. Never even give me the big M.

    Any thoughts about what went wrong?

  • Ryan C

    Worked perfect for my Droid X with 2.3 STOCK – never rooted before. Worked just as described. What do you do if you ever wish to Un-Root?

  • rick m

    Worked perfect. Silly question, if i needed to how do I unroot?

  • http://www.talkandroid.com/55906-one-click-root-for-stock-gingerbread-droid-x-droid-3-droid-x2-cliq-and-cliq-2-from-the-forums/ Frank

    need some help, I can’t get my droid x to stock. Im in Gingerdread but I first rooted when it was in Froyo. I used z4root to rooted, now when i tried to un-root it doesn’t work.

  • ScoutUnleashed

    After 2.5 days searching for a solution I stumbled across this link. I have a Droid X2 (2.3.3) and tried it. A few clicks on the PC, a few moments and TA DA! It worked GREAT!!!! Thank!s

  • Jim Isbell

    I had a rooted Froyo, one of the first that was sold. and two months ago it started giving me an error when charging batteries so I swapped it out. Now I cannot root using Z$, as expected. I am trying your method to no avail. This is a completely STOCK, brand new Droid X.

    I have all the files in a single directory on my Linux computer and the phone connected by the USB umbilical, in USB debug mode. I cannot use the .bat file as I am not running windows. When I rune the ,sh file in terminal mode I get the following errors. I see no place on either machine where I can “set the mode to PC” or “set the mode to charge only” Just doesnt exist.

    What am I doing wrong??

    chmod: cannot access `./adb.linux’: No such file or directory
    /home/oem/Documents/my-documents/Droid-X/Droid Root/DROID 3 easy root script v7/run_to_root_your_droid3.sh: line 43: ./adb.linux: No such file or directory

  • http://www.talkandroid.com Harold Williams

    Jim Isbell check out the source link as there are some update linux instructions in there.

  • Silent-X

    Awesome, worked on my D2 with the latest VZW updates, was having a hard time with gingerbreak and all the others, even the older method of rooting. Thanks alot.

  • Austin Granquist

    I have a droid X and i have tried to root it before with different methods so i need to flash it back to stock with rsd lite or whatever and i dont know how to do that because i cant get rsd to reconize my phone. any help would really be apreciated.

  • Jim Isbell

    I must be on an entirely different page than others are on. I dont see any “source” link.

  • Kevin

    cant seem to get this to work, it keeps saying that adb is not recognized, yes i am a noob with android devices…

  • http://www.talkandroid.com Harold Williams

    @Jim – the source link is the “via” link at the bottom of the post

  • wurgy

    K, i did the boot and it says I have root access but clockwork recovery won’t go into recovery. I also have droid 2 recovery so tried that and it goes in to recovery mode fine. Any ideas?

  • wurgy

    K, tried this twice now and no go. I use the .602 SBF, use the one click root above. Everything seems to be good. However when I try and use ClockworkMod to change my ROM all is does is reboot and go back to the lock screen. If I use Droid 2 Bootstrapper it goes into recovery. I’d really like to use the ClockworkMod since I just dumped money into it. Any ideas?

  • wurgy

    With the ClockworkMod I was flashing the 2nd-init not droid x….flashed droid x and it worked fine.

  • http://www.talkandroid.com Harold Williams

    @wurgy – I’m pretty positive that with GB on the Droid X you HAVE to use the Droid 2 bootstrap.

  • Michael

    Thanks very much for this simple way to root my Droid X (stock 602 from RSDLite 5.4.4 and 602 sbf file).

    Took about 2 minutes on my Windows 7×64 laptop.

    I appreciate the hard work that goes into this.

    Michael
    “I stand on the shoulders of giants” but I am a little afraid of heights …

  • Jim Isbell

    I always get to the exact same place. I find NO place on the phone or on the PC to “set the MODE to charge only” It was suggestred that when I set the USB to debugging a pulldown menu would be presented. It isnt…When I run the script it sits waiting for the phone to be connected.

    • http://www.talkandroid.com Harold Williams

      @Jim – When you plug your X into your PC you need to pull down the notification bar to change the USB mode. This has nothing to do with the rooting software and should be presented when you plug your phone into the PC.

  • Jim Isbell

    Where is it presented? On the phone or on the PC? I havent seen it and believe me I have looked. I am feeling real stupid because I have been working computers since 1960 on the IBM 7070 and thought I was a guru. But I just dont seem to find this pull down menu you are talking about…anywhere?

  • Myndmelt

    You know the top of your phone where you pull down the notification tray in android? That is where we are talking about, once you plus in the usb cable to your pc & phone.

  • Jim Isbell

    Success. I have been trying for a week to do this and all it took was to find out what was meant by “pull down the notification tray.” I had never heard it called that before!!!

  • Myndmelt

    Jim glad you got this to work. I guess most of us were fairly used to doing this by now.

    I still hope they can post some un-root instructions.

  • Jim Isbell

    I wasnt used to it because I rooted my DX almost a year ago and hadnt needed to until they sent me the new one. I hope this method will work after the next iteration of the OS which I think is coming out this month. I needed the root for tethering. I dont think I will swap to Liberty OS now because the latest Mot OS seems to be much better than the first one so it doesnt need replacement.

  • Cary Lollar

    MUCH THANKS FOR THE APP!!!
    Worked like a charm on my DX!

    Tried to use it on a friends D2 running GB without success…ended up boot looping it and had to SBF back to Froyo…guess I will have to use the other method for rooting it.

    One quick question though…is there a way to unroot the phone after this exploit has been applied?

    Has anyone tried this on the Thunderbolts or is this a Motorola specific exploit?

  • Mikey

    This is great! Has anyone tried this on a Droid X with the latest Gingerbread release – released this week, 9/21 or so, system version 4.5.605.MB810.Verizon.en.US?

    • http://www.talkandroid.com Harold Williams

      Confirmed with .605 for me

  • Caitto

    Newest version works fine

  • Jim Isbell

    Great, because I think my phone will automatically upgrade. Wish it wouldn’t. That is usually the root of all my problems. I get things working and then they upgrade!!

  • Jen

    Works great on Droid X. After upgrading with OTA .605 I re-ran the root program and it worked perfect. Titanium Backup shows full root.

  • Kenny

    Finally….Thanks you guys. This freaking rocks….
    Rooted Droid X….WOOOOHOOOO!!!!!!

  • irritated

    you should add some things to the how to. like select charge only from the pulldown menu. extract the downloaded zip to a folder on your pc. will not work in any mode besides charge only and will not root from the zip folder

    • http://www.talkandroid.com Harold Williams

      Not sure I follow what your asking for that’s all there

  • Warren

    I rooted the Droid X and it worked until I recieved a new phone update from Verizon and now the phone isn’t rooted anymore. I tried re-running to root but it doesn’t work now.

    • http://www.talkandroid.com Harold Williams

      Ran perfect for me after the update. There are a lot of different way to go about rooting the X. Do we need a post just for that and maybe I can list them all.

  • Jim Isbell

    I think I know what he is saying. The instructions are clear as a bell as soon as you have done it, but it took me several tries to figure out the nuances to get it going the first time. The instructions dont always tell you which device you are working on and the “pull down menu” is not clear as to which device and that it is the “notifications tray” at the top of the droid screen that you are talking about. The instructions should be written as though this is the first time you have ever done it with all forks in the road eliminated.

    • http://www.talkandroid.com Harold Williams

      @Jim – You’re right. I’ve updated the notification part so it makes a bit more sense.

  • Steve

    @Harold hey harold is there anyway you could help me since you got the x to root with .605… i followed all directions the phone did its thing re booted 2 times i downloaded a couple things from the market that required SU and both apps are saying i dont have root….help me please:)

    • http://www.talkandroid.com Harold Williams

      @Steve – has your phone ever been rooted before?

  • Steve

    yes sir, however i did a factory reset and wiped everything before i attempted this i recieved the OTA .605 and reminded me to try to root and i tried and failed haha, everything worked fine went through with no problems and just as it was before the attempt except the SU app and stuff, i dont get it.

    • http://www.talkandroid.com Harold Williams

      Unfortunately, a factory reset won’t completely get rid of root I don’t believe. Having been rooted before trips up this root process for some reason. I’ll see if I can dig up something on this to update the post with. Not a change you can SBF?

  • Steve

    i dont think im skilled enough i always feel like im going to mess somthing up btw i added you on google+ i think lol i googled it and pulled up your profile im assuming haha so where ever it is easier to help if you wouldnt mind thanks man!

    • http://www.talkandroid.com Harold Williams

      @Steve – I see you there not a problem

  • robbyrob

    WORKED for me! The only thing I had to do different is unplug the usb so it will actually reboot. THANKS!

  • Steve

    It didn’t work for me.

    I was rooted before the update on my X2

  • chris

    when i open the “click to root…” then press enter to root it, it keeps on saying “waiting for your phone to be connected” or something similar. usb debugging is checked, and it is in charge only mode. any body know whats wrong?

  • Jim Isbell

    OOOPs, I guess I screwed up? I just updated to 605 then I was not rooted anymore. Then, too late I read these last posts. Am I to understand that if I have been rooted under602, and then updated to 605, this procedure will not work to re-root my phone???

  • Scientific-G

    Worked FLAWLESSLY!
    Verizon
    Droid X
    Android Verasion 2.3.3
    System Version: 4.5.602.MB810
    MAKE SURE YOUR BATTERY IS FULLY CHARGED!!!!!!!

    I did the following:

    1) Ran the program as stated in the instructions

    PROGRAM STATES:
    “Running exploit part 1 of 3. Server not running”

    PHONE STATES:
    Bootloader 30.04

    Battery OK
    Connection USB

    This is where the Droid X begins to restart but “paused” or as people otherwise state, is “stuck”

    {KEY STEP}:
    i)Unplugged the phone from the USB data cable
    ii)Turn Phone off (Simple one-press of Power Button)
    iii)wait 10 seconds – Restart the phone (Long-press of power button)
    iv)As the phone displays the Red “M” plug in the data cable again.

    Let the phone restart and when the phone starts up it will then go thru the same process:

    “RUNNING EXPLOIT PART 2 OF 3. SERVER NOT RUNNING”

    Do the same {KEY STEP} for Part 2 of 3

    The phone will restart again and the next output on the program will tell you if you did or DID NOT Root successfully. If you do not get the same root as me see if your OS matches mine. Best of luck!

  • beladnj

    Worked flawlessly on 4.5.605.MB810…Thanks!!!

  • Jim Isbell

    Scientific-G, had your phone been previously rooted??

  • http://www.talkandroid.com Harold Williams

    @Jim – I was able to update to .605 and re-root again with no problems.

  • Jim Isbell

    I have found a trick that makes Bootstrap work on my .605 phone. This has always been a Catch 22 for me as people would say, reflash back to Froyo to root the phone. But the Catch 22 is that I could not start Droid Recovery from the Icon and the original boot up method would just hang at the “triangle” Icon and “search” did nothing, so could not reflash anything, so could not re-root….Catch 22

    1) Hold “Home” and press the “on” button to boot
    2) When the “M” appears, release the “on” button.
    3) When the “triangle with exclamation point” appears, release the “home” button but, DO NOT PRESS “search”. It wont work.
    4) remove the battery to reset the system
    5) replace the battery and WAIT.

    It will now boot into the Bootstrap Recovery APP and you will be ready to go.

    If you are just trying it out with no intention to go further, press the camera “shutter release” to reboot the system.

  • kmss1

    Worked absolutely beautifully for me, from totally stock GB 4.5.605! Thank you!

  • kel

    please help!!the file tries to root my phone but keeps saying: adb is not recognized as an internal or external command…

  • Jason

    Why will this root not work for flashing roms?

  • Adam

    Had rooted for the first time a week ago, this update removed it. Re-one-clicking did not fix it. After much research and trial and error I found a fix.

    http://www.multiupload.com/87HVZ6ZY2E
    Download PetesMotorolaRootTools_v1.06.zip, then unzip.
    Run Pete’s Motorola Root Tools using the same proceedure as one-click (debugging enabled, connect to computer via usb, “charge only” mode). At the bottom of the program it will give you several options. First, unroot. It will go through a 4 step process rebooting 4 times. After this, you will see superuser is now gone from your apps. Next, run Pete’s Motorola Root Tools again, only this time select root at the bottom. Voila, sweet sweet root has returned.

  • Jim Isbell

    OK, I got it rooted again, using this method. It took some doing but it worked.

    Some have said that re rooting in 605 after having rooted in 602 and then upgrading to 605 did not work for them.

    BUT…..I found a trick that makes it work.
    After starting the process it will say it is running part exploit 1 of 3 then it will say that Daemon is successfully started, then it will hang. At this point, pull the battery and reinsert it (dont press the start button) it will then complete the reboot. After the boot is done, unlock it and it will go on to exploit (part 2 of 3) and again it will hang, Repeat the battery removal and reinsertion and after reboot is complete unlock, as above.

    Now it will finish and the phone will be rooted.

    Now the next time you boot from scratch it may again hang with a blank backlit screen. If so, back to the battery reset….LOL

    It has booted properly ever since and it is rooted. There may be a better way to do this, but it worked for me.

    NOW, no more updates!!!!!!!

  • JC

    I am running Mac OSX Lion on a Mac Mini(64 bit). Trying to root droid X gingerbread .605 (32 bit i think from my research)
    What motorola drivers do I download? Do I need to look for different one than what are provided since I am not windows?

  • Jim Isbell

    I run Linux Mint and used this method on .605 yesterday. It works just fine, I downloaded BOTH 32 and 64, which it used, I havent the foggiest. Just download all the stuff mentioned in the Linux instructions and use the .su file and run it under Terminal. Not the post just above yours that tells what to do it it hangs at each exploit stage.

  • Jim Isbell

    Well, my fingers on that last sentence didnt work too well. “NOTE the post above yours that tells what to do IF it hangs…..” … LOL

  • Scientific-G

    @ Jim Isbell – Sorry took so long to reply, no, my phone had never been rooted. But I did have to unroot, so here is my procedure:

    DX, 2.3.3, 4.5.605 (OTA update)

    This worked for me. So I fucked up my phone and had to get a replacement from Verizon . . . I had rooted with Easy Root v7 and had to do some searching to UNROOT – REMOVE ROOT. Did the following procedure:

    TO REMOVE ROOT: (make sure you have everything backed-up)

    1) Download PetesMotorolaRootTools_v1.06.zip from the following website: . If for some reason the link doesn’t work email me at ebag02@iive.com and I can email you the .zip file.

    2) Run the tool and follow the steps
    (when you select unroot my phone it will ask if you want it to restore files – unless you have a droid 3 select NO – I did this on a Droid X)

    3) If you are getting a replacement or sending back to manufacturer then do a factory data reset. I took my phone to a retailer and asked them to re-flash the ROM beacuse it was acting “squirrley” just to make sure VZW doesn’t try anything funny.

    Good luck!

  • Sokudoningyou

    Ok, so, I was rooted on Froyo, then rooted on .596. I used the one-click method to install .602, and this is what I came across:

    First off, I had the ADB installation problem that I solved before I even SBF’d. However, once I SBF’d and reattached the cable (not realizing it was in USB storage mode), my computer claimed the same error, but everything worked properly, and was still showing proper installation.

    Running the 1-click root didn’t work as the instructions said. In Charge Only mode, nothing happened. I disconnected, reconnected, changed the modes back and forth…nothing. Then, when I changed to USB storage, it worked. I rebooted, installed D2, and I appear to be perfectly rooted.

  • User.

    Both the Wife and I were at .602 and kept getting prompted for the .605 upgrade. I finally gave up and downloaded/upgraded my phone.

    The script kept saying that the phone was rooted but after verifying.. it wasn’t. So the SU being installed ccause both or us had .602 Rooted… the script wasnt working.

    Solution that is fast and doesn’t include SBFing old OS versions… why waste time??

    Anyhow here’s what I did and its verified via me and the Wife’s phones.

    if the script isn’t working because you have SU installed and can no longer remove it from /system.

    Access CWR under advanced and mount system.
    Leave the phone at that screen

    From that point, I ran the dounroot.bat from DoRootWin_2.1.4 & rebooted.

    Once the phone loaded back up, I re-ran the V7 script and everything went smooth. Now, me and the wife are happly at .605. Onto that stupid Verizon WiFi-Tether Blocking issue.

    • Ferny_540

      i am new on this. what is CWR

  • Ted

    Just ran this and it worked fine on the latest .605 update that Verizon is pushing. Had no trouble running Open Garden Tether, also. This is on my Droid X that was previously rooted with z4root

    But there are a few caveats:

    1) Wipe the SD card and reset the phone to factory defaults first. After factory reset, go into settings and run Updates, just to make absolutely sure you got all of them that Verizon is pushing.
    You can reactivate the phone to get it up and running again.

    2) Run the one click batch file, when it ends it will say the phone is rooted, but it won’t be.

    3) Immediately after the batch file says it’s rooted, run “adb shell” and the commands that a prior poster put up.

    mount -oremount,rw /dev/block/system /system
    rm /system/bin/su
    rm /system/xbin/su

    Then rerun the batch file and it will actually root it a second time.

    You can run “adb shell” in a second command window that you have opened and CD’d into the directory created when you extracted the zip file.

    4) If you restart the phone after the first root attempt, then “adb shell” will give you $ and not #. Then the mount commands your supposed to run will fail.

    Don’t forget to put the phone back to PC mode from Charge mode on the USB

  • Wilton Helm

    Well I seem to be part of a trend of those getting Gingerbread OTA from rooted Froyo. I got 4.5.605 last night, and of course, lost root. Tried D3 script v7 (called ez script below). Like others it initially appeared to work, but ultimately wasn’t rooted. Didn’t feel like wiping data to SBF, so tried to figure out a work around, taking a good look at previous comments here. I know just enough Linux to be dangerous.

    Here’s what appears to be the case (from my observation):

    The ez root batch file (script) puts su in /system/xbin. As previously noted, this conflics with either an existing copy from Froyo rooting, or Froyo put it in /system/bin, and that version gets found first–not sure which–I didn’t do much playing after I got it solved.

    The rub is how to get rid of the old files after loosing root–it’s a catch 22 because you need root to do it.

    The answer is that the ez root script does give you superuser access–breifly. It appears to maybe give you one access! So here is what I did:

    Ran the ez root script.
    From a cmd window (in the same directory with the script) ran adb shell. I got # — the root prompt! At that point I followed Jims steps:

    mount -oremount,rw /dev/block/system /system
    rm /system/bin/su
    rm /system/xbin/su

    Then ran ez root script again and I was home free (well at least permanently rooted).

    caveats:

    I actually did some variations on this that I don’t think made any difference, but I will disclaim them here, in case they did. I had removed superuser and installed 3.0 before I tried anything. After having initially attempted to root and fail, I removed superuser (which simply put me back to the old one, because it can’t be removed that way. I later put 3.0 in again. I also removed and re-installed busybox. The problem with all of this (besides the fact that it is a key part of what ez root does) is that none of it ever actually affected the files that actually grant su status, because it needed root access to do so.

    Also I failed to notice that adb was part of the ez root download, so I went through the grief of getting the SDK (including Java) and ran adb from there instead. Again, I doubt that any of this made any difference.

    The key to an upgraded rooted Froyo seems to be root it, and then immediately use adb to remove the froyo leftovers and then root it again.

    • Keith

      Worked like a charm from a Froyo root to Gingerbread OTA for me on the X. Ran One-click, did adb commands above, and re-ran One-click. Back to rooted.

  • me

    worked great 4 me

  • keith

    This works great on my Droid X GB 2.3.3 .605!!!

  • Jim Isbell

    Making Bootstrap work.

    My previous post on making Bootstrap work was in error. It worked for a few days but now that I am trying to get into the bootstrap menu so I can flash a ROM, I cant get it to work anymore. The menu doesnt come up!!! It just hangs at the “Triangle exclamation point” Guess I am stuck with the Mot offering.

  • http://www.waynesstewart.com stewblack

    Thanks for the the great info.

  • Sunny

    Thank you for making it so easy. This message is to confirm that this method is still working as of today – Saturday, October 29, 2011.

  • p

    You may have already answer this question. I have a droid x system version 4.5.605. I previously had the phone rooted on froyo, but can’t get to work on gingerbread. Any help would be appreciated.

  • Wilton Helm

    It’s been a month since I did this and posted my success and it definitely worked and I am rooted on Gingerbread. The process outlined above works as it if the phone was not rooted, but requires a slight modification as noted if rooted on Froyo. The simplest way, I think is a two line addition to the script. I am not willing to unroot to try this, so feedback is appreciated. This can do no harm, but if it doesn’t work, just add optional steps. Here is the process, adapted from previous comments:

    •Motorola drivers need to be installed
    •Download and unzip ‘Droid 3 easy root script v7′ to your PC
    •Turn on USB debugging on your phone by going to Settings > Applications > Development > USB debugging(check box)
    •Plug phone into your computer and select “Charge Only” mode from your phone’s notification drop down (pull down your notification bar and tap USB connection to change).
    •Navigate to ‘Droid 3 easy root’ folder you unzipped to your PC
    •Open Click to root yuor DROID 3.bat in notepad. Go to near the end of the file. See the line
    echo * Running exploit [part 3 of 3]…
    and the next one
    adb remount
    after that insert two or three lines
    mount -oremount,rw /dev/block/system /system
    rm /system/bin/su
    rm /system/xbin/su
    The first one is probably not necessary since the line above it already is a remount command. I only included it in case it doesn’t work without it. The other two remove the rooting from Froyo which interferes with the next commands.
    •Save and exit from notepad
    The rest is as before.
    •Run ‘Click to root your Droid 3.bat’
    •Now just follow the instructions in the command window and unlock the phone after each reboot

    If for some reason this doesn’t work, the original process will:
    1. Run the unmodified ‘Click to root your Droid 3.bat’
    2. As soon as it finishes and says
    ‘ALL DONE! YOUR PHONE SHOULD BE ROOTED!’
    run adb from a command box and type these three lines
    mount -oremount,rw /dev/block/system /system
    rm /system/bin/su
    rm /system/xbin/su
    Note that adb is in the directory you unzipped on your PC. It has already been used by the .bat file.
    3. Run the unmodified .bat file a second time.

    The first time it gives you root access, but fails to install su because the Froyo version is there (or is somewhere that the OS finds first). However it leaves the phone temporarily rooted. That allows the three commands above to work and remove the old su file. The second time it works properly and rooting is permanent. Agan this three step process is probalby not necessary. Just adding two lines to the batch file as indicated should make it all work in a single step.

    • Liquidbarney

      This still works 3/1/2012

  • http://efederalstudentloans.com student loans

    Thanks for sharing your great thoughts. I have got to admit that I think you hit the target.

  • Steve

    I’m having an issue, when I try to run the One Click all it says is ‘adb’ is not recognized as an internal or external command, operable program or batch file. How do I get around this or how do I make it work?

  • Wilton Helm

    I don’t know your exact experience and skill level, so I will create a little bit of tutorial information. If it is too simple or obvious, sorry. Maybe it will help someone else instead.

    One Click comes a a zip (compressed) file that contains several files that need to be extracted to your hard drive. One of them is adb.exe. Where the zip file is extracted to is left up to the user. You presumably know the directory where this was done or you wouldn’t be as far along as you are. Another file in the directory is “Click to root your DROID 3.bat.” That is the one you click on to start the process. It is a script file full of instructions given to your phone by adb.exe.

    For some reason, Windows explorer isn’t figuring out the directory it is running it from, which is probably why it can’t find adb.

    I would strongly suggest you create a directory directly under C:, your primary hard drive directory and unzip to that, rather than using the default download location or any location down the My Documents path. For example you might call it DroidFix. Names without spaces also keep life simpler. That is where the zip file you downloaded should go and where its contents should be extracted. If they are somewhere else you can drag them there instead. That alone may solve your problem. Try clicking on “Click to root your DROID 3.bat” in this directory and see if it works.

    If it doesn’t, running the script from a command prompt probably will. Accessing a command prompt differs depending on what version of Windows you use. XP is what I use and am most familiar with. Click on Start (generally lower left corner of screen)and then Run. Type Cmd and click OK. You will get a new text based window with a prompt character (“>”) generally with some text in front of it telling what the current directory is. Type
    cd c:\DroidFix
    or whatever you called the directory you just created and put the files into. Press the key. You will probably notice that the text in front of the prompt changed to something like
    c:\DroidFix>
    Typing
    dir
    Will show you a list of the files in the directory. One of them will be adb.exe, which is what Windows couldn’t find. Another one will be one with a long name “Click to root your DROID 3.bat”. Type that name in (you don’t have to type the .bat part), followed by the key and the whole thing should start and run fine. Because you are in the same directory with adb, the computer should have no trouble finding adb.

    Once you are done you can close the Cmd window and use Window Explorer to remove the directory you created including its contents.

    I hope that helps.

  • Max

    how do i know what driver i need for my droid x?

  • Craig29520

    WORKS GREAT!!!! Followed all instructions and installed without any problems.

  • Shyquan Fludd

    FAST AND SIMPLE on my Droid X running with 4.5.605. The only thing that could have made this easier is through telekinesis, lol… Now on to removing bloatware and overclocking :-)

  • Shyquan Fludd

    FAST AND SIMPLE on my Droid X running with 4.5.605. The only thing that could have made this easier is through telekinesis, lol… Now on to removing bloatware and overclocking :-)

  • Beastmode Woods

    Thank you i was so pissed when i cracked my old droid x then received a new one that was all up to date with verizon bs thought id never be able to get it rooted again I tried many different things to root nothing worked them came across this worked quicker and easier than i could of imagined good stuff.

  • Endon

    Thanks for the guide, Just did a successful OTA Gingerbread update from rooted Froyo, went extremely smooth.

    Here is what the .bat file looks like with the extra rm command for all that are interested in streamlining the process:

    adb kill-server > NUL
    COLOR E0
    adb wait-for-device > NUL
    adb wait-for-device > NUL
    COLOR B0
    echo *
    echo * Running exploit [part 3 of 3]…

    adb remount
    adb shell rm /system/bin/su
    adb shell rm /system/xbin/su
    adb push busybox /system/xbin/busybox
    adb push su /system/xbin/su
    adb push Superuser.apk /system/app/Superuser.apk
    adb shell chmod 4755 /system/xbin/su
    adb shell chmod 755 /system/xbin/busybox
    adb shell chown system.system /data

    echo *
    echo * ALL DONE!  YOUR PHONE SHOULD BE ROOTED!
    echo *

    • ATechGuy

      The two extra RM lines were needed in my case. I had been rooted, did the OTA and then the regular script didn’t do it. Did it twice. No go. Added the two lines as above and I’m good.

      Nice to be “back”…:-)

  • http://www.facebook.com/IndustrialJay84 Jay Karl

    How do you un-root if needed?

    • Davidaw13

      Factory reset.

  • DNQ_X

    So this will work on 4.5.603? just curious. Since the reminder is annoying me.

    • DNQ_X

      or whatever the newest OTA is.

  • Pkhermouch

    When I run this, it just repeatedly says that “adb” is not a recognized program, even though it is sitting right in the folder.

    • Baltojoe

      me too  adb not an operable cmd file   droid x

  • Pkhermouch

    Ignore that, I saw the comments below.

  • siimzo

    i rooted my Droid X running 4.5.605 sucessfully, but my phone is the same? how do i know its even rooted now. and what process will install new ROMS?

    • Davidaw13

      You have to install rom to your SD card and boot into bootloader, wipe everything in your internal storage and wipe your cache. Then flash the rom u put on your SD. When all that’s done turn on your phone and you have your rom.

  • MB810

    Worked flawlessly after the OTA update. Great big thanx.

  • Danz9333

    Works perfectly!

  • Michelob39

    so i have rooted my droid x and have been granted super user access but everytime i try to use the tethering hotspot, verizon sends a message, to my tablet where i want to access the phones tethering.  the message reads as self provisioning and will auto bill me for for hotspot usage.  does anyone know how to block out verizon and just allow me to get the tethering activated.  i have unlimited web acces on my verizon plan so it should not matter to them how i access the web.  can anyone help? 

    • Davidaw13

      Its technically against Verizon’s contract to do that… but there’s an app on the market called open garden wifi tether try that. The stock tethering app wont work right even with root unless you pay the 20$ a month fee.

      • Cjackson0913

        how do you root the droid x 2

      • Rrfanti

        Use Wi-Fi Hotspot-works like a charm!

  • David A Lukas

    Droid X running 4.5.605. Worked flawlessly, took less than 5 minutes! Thanks!

  • Mikejm70

    i downloaded the droid3 easy root script to my macbook and when i went to open it, it said i did not have the application needed to open the file. does anyone know what application i need to open this file?

    • Alden

      It is a .bat file, i think it needs a DOS based windows system to run.

  • Dave Thomas

    thank you.  worked like a charm on DX 4.5.605VZW

    • Christian Walls

       I have the same thing through VZW, and I can’t get mine to do squat

  • Brandon

    worked great for my dx!  thanks!!

    • Christian Walls

       How did u do it?  I’ve followed all the instructions as well, and I can’t get passed the 1 or 3 part….lol

  • Guest

    Didn’t work on my Galaxy Tab P1000 FW.2.3.6 Gingerbread.XWJQ8

  • Guest

    BUT…tried SuperOneClick2.3.2 and it did work. (P100- FW.2.3.6 Gingerbread.XWJQ8)

  • Jmills55412

    Thank you for your help. I had the same problem and now my Droid X2 is rooted!

  • http://www.facebook.com/profile.php?id=23406515 Ryan Landry

    How do I know if I need a 32 or 64-bit driver? I’m kind of new at the whole rooting thing… Moto X2. Any help rooting and not bricking my Droid would be appreciated

    • Abbyhayes22

      If you hit the button with the windows logo and the pause/break key at the same time it will pop up a properties window that will tell you if you are running 32-bit or 64-bit. You have to minimize all of your windows before you press those buttons though.

  • Shawn

    Depends on which version of Windows you are running.  64 bit or 32 bit version.

  • Kiillertopgun23

    i farted and it hurts

    • Rainey Grimes

      Maybe you blew your asshole out

  • Abbyhayes22

    Nice job. Thanks!

  • Anthony

    Im in that box of because I was previously rooted I have problems getting Superuser installed. Sorry if this is long winded but I have been at this for two days now just reading all over the net, and trying to re-root my phone. Background: I have a Droid X2 that was a stock Froyo and rooted using Z4 Root. Updated to Gingerbread 2.3.3. middle of last year and lost the root. The weird thing is that the Superuser Icon in applications is still there. I am assuming this is why I cannot root again since attempting the root following the above directions failed. To be clear I downloaded the drivers 32bit here, and also Droid 3 easy root script v7′ here , and unzipped. Insured USB debugging was checked, and in the charge only mode. Clicked to root the Droid 3.bat. I get the Motorala One Click  Root command window which stays up, but followed by a send error report pop up saying Motorola One Click Root has encountered a problem and needs to close.(buttons for sending report or dont send available in the pop up) Even found Pete’s Motorola Root Tools for 2.3.4 and gave that a try. Actions result with Error: we have root, but couldn’t push su, try re-rooting first, then unroot. So my questions other than {“WTH do I need to do?}” are, is the previous Z4 root and the fact that the Superuser Icon is still showing under applications preventing what should be an easy root process? I have tried without success to delete the su icon from applications but have failed. Even after going into SD card via my pc and removing the Z4 root .apk files. And when going into the manage applications through the phone the su is not showing up thus preventing a deletion attempt from there. My goal is root 2.3.3 and not attempt to flash back to froyo as I have some game apps I would otherwise lose as the Devs have an updated version. Which I would then be forced to play on in the redownloading of the game. I want to stay on their old version as long as I can. They dont make the older version available anymore but still running it on their servers. The catch 22 is that if I was rooted I could save the version with Titanium Back up and flip back and forth on both versions. Clearly not the case and apologies for the digression. Need some well though out suggestions and pointers here on how to get over this hum and be rooted again. Thanks for your time, regards, Anthony. anthony@soulorbit.com<———if anyone has the time and would like to take establish a pvt convo. I will be happy to post back here How the issue was resolved in full detail. I cant be the only one stuck like this. Thanks again!

     

            

    • Edgarht82

      I’ve seen a couple people run into the same issue…. as far as I knowledgeable the only thing that has worked was to do a FULLY SUCCESSFUL “SBF flash” back to bone stock…. after that this one click method works flawless…. good luck…

  • Caleb Longoria

    Hi, can anyone help me? I rooted my Droid X and everything went smoothly. But none of the tether apps seem to work, I mean even remotely work. They all stay something like “starting” but that’s as far as any of them go. Can someone pleeeeease help me. If you could email me, caleb.longoria@gmail.com thank you.

  • Guest

    Confirmed: works with Gingerbread.
    Verizon Moto Droid X, 2.3.3, 4.5.605

    Flawless victory

  • Abelnr

    So when i try to root the screen for the program on the computer goes all green and says at the bottom ‘ adb’ is not recognized as a internal or external command, operable program or batch file… does this instantly when i hit a key to continue… anyone know what this is??

  • J Vazquez

    Root fails.  Any ideas?

    Thanks.

    Droid XSystem version: 4.5.588.MB810.Verizon.en.USAndroid ver: 2.3.3Boot loader:  30.04Build:  4.5.1_57_DX5-18

    Bat file shows OK until part 3 of 3:

    * Waiting for your phone to be connected…** Running exploit [part 1 of 3]…** Rebooting the phone… please wait.** Running exploit [part 2 of 3]…** Rebooting the phone… please wait.** Running exploit [part 3 of 3]…remount failed: Operation not permittedfailed to copy ‘busybox’ to ‘/system/xbin/busybox’: Read-only file systemfailed to copy ‘su’ to ‘/system/xbin/su’: Read-only file systemfailed to copy ‘Superuser.apk’ to ‘/system/app/Superuser.apk’: Read-only file systemUnable to chmod /system/xbin/su: No such file or directoryUnable to chmod /system/xbin/busybox: No such file or directoryUnable to chmod /data: Operation not permitted** ALL DONE!  YOUR PHONE SHOULD BE ROOTED!*******************************************************************************

    • JVazquez

      It left out the carriage return/line feed command.  Hopefully this will be more readable:

      Droid X 

      System version: 4.5.588.MB810.Verizon.en.US 

      Android ver: 2.3.3 

      Boot loader:  30.04 

      Build:  4.5.1_57_DX5-18 

      Bat file shows OK until part 3 of 3: 

      * Waiting for your phone to be connected…* 

      * Running exploit [part 1 of 3]…* 

      * Rebooting the phone… please wait.* 

      * Running exploit [part 2 of 3]…* 

      * Rebooting the phone… please wait.* 

      * Running exploit [part 3 of 3]… 

      remount failed: Operation not permitted 

      failed to copy ‘busybox’ to ‘/system/xbin/busybox’: Read-only file system 

      failed to copy ‘su’ to ‘/system/xbin/su’: Read-only file system 

      failed to copy ‘Superuser.apk’ to ‘/system/app/Superuser.apk’: Read-only file system 

      Unable to chmod /system/xbin/su: No such file or directory 

      Unable to chmod /system/xbin/busybox: No such file or directory 

      Unable to chmod /data: Operation not permitted 
      *
      * ALL DONE!  YOUR PHONE SHOULD BE ROOTED! 

      *******************************************************************************

  • Jjshibbydude

    how long should it take to reboo? mine is stuck at a black screen with a small amount of info.

  • Me

    I had a verizon rep tell me on the phone that rooting would remove the throttle they put on my phone. Oh wait, the ‘network optimization’ that has ‘been applied’ to my phone….
    whatever…. it’s throttling.
    Anyway. Used this. Rooted fine. Really easy. Superuser is in the app tray.
    Is there any other way to confirm it’s rooted?
    Cause, instead of mobile broadband, I have mobile dialup…

  • Me

    Strike that, just rebooted.
    AND AM NOW STUCK AT THE MOTOROLA LOGO!

    Thanks a mil for such a great app.

  • Anonymous

    just in case how can i uninstall this?

  • Jrebel11

    well i have a motorola Droid A855 and ive tryed everything to flash mine and root it all else fails 

  • AlexP

    I have a cliq 2 with the gingerbread leak (just installed it), and this worked perfectly. thanks!

  • Jon M

    Thanks Guys! Mine was freezing on the rebooting steps, so I used Scientific-G’s method below and it worked perfectly :)

  • nick

    when i try to download the drivers the download is unsuccessful.. what can i do?

  • Guest

    Mine rooted fine on .602 GB flash so idk what you guys are talking about.

  • http://www.facebook.com/lolololfynnnny10101 Adam Israel

    Oh it requires adb? Fail

  • Anonymous

    i have the droid x with the new 4.5.602 update from the other day i tried to root my droidx it did part 1 of 3 sucesfully  but parts 2 of 3 and 3 of 3 failed commands not allowed but got message at end said it should be rooted succesfully its not rooted what else needs to be done

  • Bvhu13

    Hey i was wondering if anyone could help me i tried to root my droid 2 (2.3.3) using this and maaaaaannnnyyyyy other methods just like it but every time i try it finishes step 1 says rebooting then goes to something called bootloader and does not reboote 

  • Raynah7

    i rooted my droid x2 works on my x box but my laptop wont read it … it will connect to it but it wont give me internet

  • Christian Walls

    Hi guys…I’m new here & to the whole rooting experience.  I’ve been trying to root my X for awhile now, but I must be doing something wrong.  I’ve followed all the instructions and nothing is working.  Plzzzzz help…..lol
     

  • Andrew

    awesome! worked like a charm! takes no knowledge of android to do it. as long as you can follow instructions…stock Droid X is now rooted! 

  • Alidust42

    So this will work for Droid x2 on stock 2.3.6?

  • Smartpartsagp

    first time rooter..took me 10 min on droid x2 and done

  • DroidX2User

    Ive rooted a few phones before, this is the first time ive ever been lazy and tried a scripted root…well done, saved me a ton of time and frustration! Id recomend this to anyone with an applicable device.

  • Alidust42

    Ill give it a shot b/c I am ov searching and reading and I read nonstop all the time but damn it I am burnt out lol that’s my luck. Tried everything else hell why not this one.

  • http://www.facebook.com/steelmiked Mike Davis

    Ok, so I have tried this several times but it is not
    working.  I have a Droid X, Android version
    2.3.4, system version 4.5621.  It has not
    worked yet.  I too keep getting the same
    thing as  JVazquez.   How or what
    am I doing wrong.  I am following the
    directions and keep getting the same results.

  • Egana92

    still not seeing my phone as rooted

  • http://profile.yahoo.com/N3I5A666R6NRKBDIJQBJBC4GRU Shariq

    I have HTC Incredible S purchased in China Mainland. I can’t access the Play Store and some other apps like GTalk, Voice Actions, Voice Search. Every time I try to access and process if closed forcibly. The device is running GB 2.3.5, HTC Sence 3 and un-rooted.

    What should I do to rectify this problem?   

  • JEREMIAH VILLA

    i know im late to doing this but i wanted to get my droid x i just got, (late. but fuck you it was a free phone) switched to straight talk and in researching it lead me to this thread, i did everything above as correct as i could, 5 times. still no root.. idk it just kept saying everything permission failed and servers not found.. idk if its too late to do it or what but i knwo i did just get it from my bud with no previous rooting to it, if anyone can get back with a solution it would be cool guys thanks.

  • http://eazyigz.wordpress.com Igor Ganapolsky

    Very good guide. Rooted my X very easily. You might want to point to this easy_root file though: http://bit.ly/15B9th6