Samsung says Galaxy S III is safe from USSD exploit and is conducting an internal review for other phones

Yesterday we told you about a major security vulnerability with Samsung phones like the Galaxy S III, Galaxy S II, Galaxy Beam, and Galaxy Ace. This vulnerability could cause your phone to conduct a factory reset from visiting a website containing malicious code. Samsung just confirmed that the Galaxy S III should be removed from this list, well at least ones running the latest software.

“We would like to assure our customers that the recent security issue concerning the GALAXY S III has already been resolved through a software update. We recommend all GALAXY S III customers to download the latest software update, which can be done quickly and easily via the Over-The-Air (OTA) service.”

So make sure your GSIII is up to date. As for owners of the other phones, Samsung said they are “currently in the process of conducting an internal review.” I’m sure Samsung will get updates to all phones affected so stay tuned.

source: androidcentral

» See more articles by Robert Nazarian


  • http://MyShocker.com Nudo

    Lol