Some Nexus 5 users experiencing issues with Google Now, Google recommends sending in feedback


If you own the new Nexus 5 and experience some trouble with Google Now, you’re not alone. According to multiple reports, Google Now is not functioning properly on the new device and it is also effecting other Android devices that they own. In some cases, Google Now doesn’t load any information, rendering it useless. The app will not sync and is even crashing when activating it for the first time.

A solution for the issue has been to sign out of their accounts and then signing back in; however, this hasn’t been a successful resolution for many. Some people have even performed a factory reset, but that too has been hit or miss. Android Police explains that it could be due to Location History being turned off or not available. Certain countries do not allow location tracking; therefore, they would be left out from using Google Now.

Google is recommending that users send in feedback from their device. To do this, go to Settings / Help & Feedback / Send Feedback.

Source: Google Product Forum
Via: Android Police

  • GraveUypo

    google requesting feedback?
    google doesn’t care about feedback. they never listen to anyone.
    look at youtube. it’s hell on the internet, and they’re just letting it burn.

  • crhylove

    Lol@google. I tried the new search today. I said,”OK Google.” Then “play pink Floyd” it brought me to a useless menu. Fail

    • deano

      yes….you fail

  • C Jacobs

    2 dumb asses attempting to be funny….

  • Bro

    Mmm nexus5 doesn’t have option for feedback in settings menu

  • Netdoctor

    Go to settings, language & input, voice search, unchecked word detection wait 5 seconds recheck voila

  • fredphoesh

    No problem at all with mine.

  • rodolfo cruz

    To me no problem!★

  • Raj

    Google Now on my nexus 5 doesn’t detect the voice . Whats the solution friends???

    • Tony Baloney

      Mine worked out of the box, then stopped – I narrowed it down to using a non USA english set (australian or something, possibly). Once I switched back, it worked again. I am able to use UK english, though. Try that?