LG publicly apologizes for statements concerning 1 GHz CPU requirement for Gingerbread

Remember yesterday, when LG was saying there was a 1GHz requirement for running Android 2.3, and because of that, a lot of phones wouldn’t be updated? We later gave you a statement from the Open Source Lead at Google, stating there was no requirement. Basically, the whole thing took a really bad turn, and sounded really strange.

We have now gotten a tip that LG is announcing that they are apologizing for the mixup. According to LG:

LG released information prematurely regarding the minimum processor upgrade requirements for the LG Optimus. Google recently announced the Gingerbread platform and has not yet published the Gingerbread Compatibility Definition Document (CDD) or the public branch open source code. Once the CDD and the source code is public, LG will evaluate the upgradability of the Optimus Series. We apologize for any confusion or misunderstanding. We will alert you as soon as more information on this topic is available.

Sounds like someone jumped the gun on the official LG Facebook page. Just do it like Santa next time, guys; make your list, then check it twice. Be sure to let us know your thoughts in the comments. Thanks Brian for the tip!

[via LG]

  • Joshua M.

    Yea I read your guys story stating that there was no 1ghz requirement and I went right on LG’s facebook page and called them liars who just what to make there customers have to buy there new phones so they can make more money off them….they deleted it lmao :)